I am trying to launch a gui application on a Windows 2008R2 64bit server using your PaExec utility. When I try to use the -d parameter PaExec does not detach from the process and freezes until the application is exited on the server console.

When I put the -d before the server name and application name I get error code 3 C:DownloadComponentsPaExec>paexec.exe -d cloud01 c:AppsTestSuperBeatDefault1.0Test.exe

PAExec v1.5 - Execute Programs Remotely Copyright (c) 2012 Power Admin LLC www.poweradmin.com/PAExec

PAExec starting process as current user: "cloud01" c:AppsTestSuperBeatDefault1.0Test.exe Failed to start "cloud01" c:AppsTestSuperBeatDefault1.0Test.exe. The system cannot find the file specified. [Err= 0x2, 2]

PAExec returning exit code -3

C:DownloadComponentsPaExec>


When I put the -d after the servername and the application name the application runs but PaExec does not exit until the application is exited on the server console.

paexec.exe cloud01 c:AppsTestSuperBeatDefault1.0Test.exe -d


The -i parameter seems to have no affect on the execution of the application at all. With PsExec the application will run in the service process if the -i is not included. With PaExec the application always runs in the console session.

asked 25 Oct '12, 18:26

MikeInOr's gravatar image

MikeInOr
310114
accept rate: 0%


I seemed to have gotten an old version (1.5) of the PaExec utility. I downloaded it again and now have version 1.11. Further testing with ver 1.11 seems to show that it suffers from the same problem as PsExec in that I can not get the GUI application to ever interact with the desktop. But I did figure out that the parameters are order sensitive. So It appears that I have to put the -i and -d between the server name and the application path. When I do this version 1.11 still does not make the gui application interactive. I assume that with the -i {argument} the argument should be the session number as shown in the remote desktop services manager.

By going back to version 1.5 and putting the -i and -d parameters between the server name and the application name the gui application does load in interactive mode and PaExec does terminate leaving the Gui application running on the server. But neither ver 1.5 or 1.11 seem to like an argument of the session to run the application in.

So, version 1.5 is working now that I know the parameters are order specific but version 1.11 does not seem to work.

link

answered 25 Oct '12, 19:29

MikeInOr's gravatar image

MikeInOr
310114
accept rate: 0%

edited 25 Oct '12, 19:37

Hi Mike --

The PAExec options do have to be in this order:

PAExec {server} {options} app.exe {optional app.exe options}

So with -d at the end, the -d was getting passed to your application.

We'll look into why the -i isn't taking the session number.

(29 Oct '12, 09:50) Doug ♦♦

Thank you for the feedback Doug. Version 1.5 is working very well for us. We have some legacy task based applications that have not been converted to windows services yet. Version 1.5 is allowing us spin these applications up on virtual servers in an automated fashion. Thank you for the wonderful utility!

I am implementing version 1.5 with the -i prompt with no session arguement and our applications are popping up on our console session beautifully. When I use the -i with no arguement in version 1.11 it always pops the application up in session 0 which is the services session and not accessable. As stated above when I add a session number arguement to the -i it does not seem to have any effect on the session that the application is launched in on version 1.5 or version 1.11.

Thank you, Mike.

link

answered 29 Oct '12, 12:07

MikeInOr's gravatar image

MikeInOr
310114
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×52
×1
×1

Asked: 25 Oct '12, 18:26

Seen: 6,380 times

Last updated: 29 Oct '12, 12:07