When I try to run on a Windows 7 64bit host: paexec \xxx.xxx.xxx.xxx -u Administrator -p xxx qwinsta

I get the following error: Remote app failed to start. Returned error: Failed to start "qwinsta". The system cannot find the file specified. [Err=0x2, 2]

PAExec returning exit code -9

When I try to explicitly state where the file is (I have checked that the file actually is in that directory) I still get the same error paexec \xxx.xxx.xxx.xxx -u Administrator -p xxx c:windowssystem32qwinsta

WHen I copy the qwinsta.exe from c:windowssystem32 to c:windowssyswow64 the command works. The strange thing is that I still try to start the application in c:windowssystem32 and not in the sysow64 directory. paexec \xxx.xxx.xxx.xxx -u Administrator -p xxx c:windowssystem32qwinsta

Any ideas on how to get this to work or anything more that I might try?

asked 03 Aug '12, 07:33

ef02lajo's gravatar image

ef02lajo
210114
accept rate: 0%


PAExec is a 32-bit application. Because of that, it is under the WOW64 File Redirection 'feature' in Windows. To get around it, use the -dfr option:

-dfr Disable WOW64 File Redirection when launching the new process

link

answered 03 Aug '12, 10:46

Doug's gravatar image

Doug ♦♦
10.1k112037
accept rate: 21%

edited 14 Aug '12, 16:40

1

Thanks, I had missed the -dfr option since I used psexec before but that one just hangs when executed via jenkins.

Added -dfr to my command and now it works on both 64 and 32 bit computers.

(03 Aug '12, 14:10) ef02lajo
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×52
×1

Asked: 03 Aug '12, 07:33

Seen: 5,747 times

Last updated: 14 Aug '12, 16:40