I am currently investigating an issue that I don't fully understand. I have not had the time to look at it in detail, so I am sorry for the brief explaination. I thought I would let you know now in the hope you can reproduce it because I will only be able to come back to it in a couple of weeks. It forced us to start using PsExec instead of PaExec. It has to do with the -i parameter. It seems the desktop interactions don't work properly.

Here is what we were doing (simplified: we run a custom program but the problem seems to reproduce with notepad): The call is in a batch file (Init.bat) called with parameters (Init.bat "output.txt"). In the batch file we have:

paexec //other-comp -i -u User -p Password -c -f MyBatch.bat %DEV_PATH% %1

Where MyBatch.bat has something like:

set TEMP=%1
@start "notepad.exe" %2

PsExec opens Notepad on the remote computer desktop with the given file open. PaExec gets stuck or doesn't open notepad at all.

In our particular case, the program needs the environment variable set right before it, but even with Notepad not needing it, it still reproduces the problem.

asked 17 Jan '13, 14:12

Galaga's gravatar image

Galaga
31228
accept rate: 0%

edited 21 Jan '13, 15:47


I wonder if -i is part of the issue (PAExec seems to have struggled with that command). We've just reworked the -i handling (v1.18) so hopefully it will work better for you. We're also going to start keeping all of the older builds around for cases when someone wants to go back.

link

answered 22 Jan '13, 17:29

Doug's gravatar image

Doug ♦♦
10.1k112037
accept rate: 22%

The new version (1.18) does not solve it. Worse, it actually broke some things that worked with 1.17 (with -i).

Sorry I am not giving you more, I still don't have much time. Did you reproduce the initial problem?

link

answered 23 Jan '13, 10:27

Galaga's gravatar image

Galaga
31228
accept rate: 0%

Hello

I've been trying version 1.19 with the newly reworked -i flag. I have a similar problem to the original poster, here is what I do:

paexec //other-comp -i -u User -p Password notepad.exe

This gets me the Windows 7 'Interactive Services Detection' popup on the remote computer. Which is undesired. With PsExec, notepad just launches properly. I read around on the web and I saw that notepad probably tries to start in session number 0, used for services. So I tried this:

paexec //other-comp -i 1 -u User -p Password notepad.exe

But I get the same 'Interactive Services Detection' popup on the remote computer.

I then disabled the 'Interactive Services Detection' Windows Service entirely on the remote computer. It removed the popup on the remote machine, but notepad doesn't start interactive (ie: the window is not visible though notepad.exe is running).

Any suggestions?

On a slightly related note, PsExec isn't perfect either, on our latest Windows 7 image with latest patches, between every call to PsExec we need to wait 60 seconds, otherwise we get an 'access denied' error message from the remote computer. this was not present a few months ago with the same PsExec version. So something has changed in the OS also.

Thanks very much for any help.

link

answered 15 Apr '13, 12:18

Pat's gravatar image

Pat
1
accept rate: 0%

About PsExec, the 60 second delay is removed by enabling the service: Application Experience (aelookupsvc)

link

answered 15 Apr '13, 12:56

Pat's gravatar image

Pat
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×52
×12
×11
×2
×1

Asked: 17 Jan '13, 14:12

Seen: 9,050 times

Last updated: 15 Apr '13, 12:56