I'm trying to run a PowerShell script, and I noticed that the PA Server is using PowerShell version 2.0 when I have 3.0 installed. Is their any way to change what version it is using? The server is a Windows 2008 server with SP2. Were running PA Server Monitor Ultra V5.1.0.34.

asked 30 Apr '13, 14:17

jlundstrom's gravatar image

jlundstrom
111
accept rate: 0%


Hi,

It sounds like version 2 is the default for your server. You are welcome to try adding code in your script to use version 3. the Execute Script Monitor has not been tested using version 3 so I'm not sure what the results will be.

I'm not sure but this link may help you with code to switch between v2 and v3. Run PowerShell in Version 2 While PowerShell V3 RC Is Installed

Thanks
Quinn

link

answered 03 May '13, 12:15

Quinn's gravatar image

Quinn ♦♦
14.0k3925
accept rate: 37%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×42
×11
×8

Asked: 30 Apr '13, 14:17

Seen: 3,340 times

Last updated: 03 May '13, 12:15