Hi,

Since Windows 10 (at least 1809), I'm unable to execute a program from a network shared folder (NAS Synology or Windows Shared folder) on a non domain computer. The share access is authorized for everyone without password (guest). I can access it when I'm on the remote client via explorer without problem.

Test with a remote client in workgroup :

  • This command "paexec.exe \remote-client -u administrator -p password -i -d \serverIPshareprogram.exe" start the program but there is no interactive GUI

  • The same command with -s don't start the program and i've got an error code 9 (file not found on NAS share / access denied on Windows share) from paexec

Test with a remote client in domain : - Everything works fine, program starts and I can see its GUI

Is there a way to make it works correctly on a workgroup computer ?

Thanks for your time.

asked 17 Jun, 03:36

tatanas's gravatar image

tatanas
112
accept rate: 0%

edited 17 Jun, 05:15


Like I said, it's working on Windows 7. It seems Windows 10 blocks PaExec routine when the programm is on a network shared folder. Even if the share is completly open. As soon as the Windows Client joined a domain, it works.

link

answered 22 Jun, 09:43

tatanas's gravatar image

tatanas
112
accept rate: 0%

AV is disabled. No problem with Windows 7.

Here is the log :

User: 'administrateur', LocalSystem: true, Interactive: true, Session: -1

Not using redirected IO: DontWait=1, Interactive=1

Got Local System handle

Using SessionID 6 (interactive session)

PAExec starting process ["\\172.20.143.85\applications\mindview4.exe"] as Local System

Failed to start "\\172.20.143.85\applications\mindview4.exe". Le fichier spécifié est introuvable. [Err=0x2, 2]

PAExec service stopping

link

answered 18 Jun, 07:10

tatanas's gravatar image

tatanas
112
accept rate: 0%

edited 18 Jun, 07:15

Looks like the file can't be found. Maybe this is a permissions issue.

(18 Jun, 09:19) Quinn ♦♦

Hi tatanas,

I'm not sure it why it fails. Try running it with -rlo, this will create a log file where you might find some hints to the reason why it stopped.

https://www.poweradmin.com/paexec/

Also, somethin you will want to check is the Antivirus application running on the remote server. It maybe stopping PAExec. You should be able to whitelist PAExec.

Thanks
Quinn

Please make sure to mark your questions accepted when you have your answer by clicking the gray checkmark to the left of the answer.

link

answered 17 Jun, 10:44

Quinn's gravatar image

Quinn ♦♦
14.3k3925
accept rate: 36%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×5
×2

Asked: 17 Jun, 03:36

Seen: 399 times

Last updated: 22 Jun, 09:43