Well i have some Problems with PaExec. I dont know why sombedy else asked it yet. Maybe it doesnt work only on my system. So i read that line "If you find a case where PAExec behaves differently from PsExec, we would be interested in hearing about it, including the command-line that was used." and thoght i explain my problems.

so first the -n option

(i tried it with a username which doesnt exist, so he can trie connecting as long as he wants to): the only thing what i can do whit it is to say if the program should try after ca 24 seconds to start the service on the remote system or not. so if i say for example -n 1 he tells me after 24 seconds that he faild to connect and afterwards he says a timeout has occured but on psexec he stopts after 1 second and if i say -n 26, after the 24 seconds he trys to start the service on the remote system and goes on as if the -n option was not setted

next one -i:

in psexec it works well but in paexec for example "paexec \pcname -u username -i -p password blub.exe" he doesnt realizes that there is a -i setted. the same happens if i write the -i before the -u username or somewhere else. but when the -i is the last setted option like here ""paexec \pcname -u username -p password -i blub.exe" hey says "Reached end of command before seeing expected parts" and shows me the help

next one -s:

"psexec \pcname -u username -p password -s cmd" for example works well the same command with paexec tells me that i can use the -s only without the -u option ... but how should i connect to the target-pc without the username? when i create specialy for that command a new user with the same password, it works, but thats really not what i want.

-cnodel:

my command here is for example "paexec \pcname -u username -p password -c -cnodel C:\hallo.bat" here he says "cnodel is not a recognized option" and shows me again the help

-clist:

"paexec \pcname -u username -p password -c -clist C:\bliblablub.txt" again shows me the "Reached end of command before seeing expected parts" message with the help.

-csrc:

well, here i dont know exactly what it is used for. if i understand it, it is only usefull if i have a file, which should be copied, but the copying fails and then he looks at the -csrc and trys to copy the file from here. but it seems to me not rly usefull so i think that this is for another usecase.

on my pc is a 32bit windows 7 enterprise SP1 and the target is a 64bit windows 7 ultimate SP1. so i hope you cold help me. if you have any questions, just ask thanks for reading ^^ i know its a long text

asked 30 Oct '12, 09:34

B%C3%B6rnib%C3%A4r's gravatar image

Börnibär
160114
accept rate: 0%

edited 30 Oct '12, 09:36


Hi Börnibär -

Thanks for your detailed post. What version of PAExec are you using?

-n: So if I understand correctly, PsExec will honor the timeout for connection, but then whether it connects or not, will still try to run the command?

-i:

This one is very tricky. Since it was (unfortunately) defined to take a parameter or not, it's hard to know if the thing that comes right after it is a session identifier or not. For example, with PsExec, the following will try to launch sess as though it was an executable:

PsExec \\computer -i sess app

So neither app seems to support -i as the last option. I'm not sure how to improve this in the parser.

-s:

Oh, I didn't know -s and -u could be used together in PsExec! It's now enabled in PAExec :)

-cnodel:

This one is simply a bug. Fixed.

-clist:

In the example given, the C:\bliblablub.txt file has a list of files to copy. But the command doesn't specify which app to launch (ie it needs blub.exe appended to the end).

-csrc:

This one was really added for us :) If you want to launch C:\Test.exe on the remote server, but the file exists in C:\MyFiles\Test.exe, then you can use -csrc to tell PAExec where to copy the source file from.

As I mentioned above, two fixes were made and the new version is now on the PAExec website

link

answered 30 Oct '12, 11:28

Doug's gravatar image

Doug ♦♦
10.1k112037
accept rate: 21%

edited 17 Nov '12, 14:36

Hi Doug

i used the 1.11 version. I tried the -i one time with a 1.06 version too but same effect.

-n: Both try to start the service whether they connect or not, but in this example whit PsExec

C:\Users\DarthVader>psexec \pcname -u notavailableusername -p senselesspassword -n 1 cmd

PsExec v1.98 - Execute processes remotely Copyright (C) 2001-2010 Mark Russinovich Sysinternals - www.sysinternals.com

Timeout accessing pcname.

he trys only 1 second to connect and changes the message to "timeout accessing pcname."

but with PAExec

C:\Users\DarthVader>paexec \pcname -u notavailableusername -p senselesspassword -n 1 cmd

PAExec v1.12 - Execute Programs Remotely Copyright (c) 2012 Power Admin LLC www.poweradmin.com/PAExec

Connecting to pcname...

Failed to connect to \pcname\ADMIN$. Anmeldung fehlgeschlagen: unbekannter Benutzername oder falsches Kennwort. [Err=0x52E, 1326] Failed to copy [C:\Windows\system32\paexec.exe] to [\pcname\ADMIN$\paexec.exe] -- going to try to continue anyway. Anmeldung fehlgeschlagen: unbekannter Benutzername oder falsches Kennwort. [Err=0x5 2E, 1326]

Timeout connecting to pcname...

PAExec returning exit code -5

So hey trys to connect -> the timeout occures but paexec dont stop -> it trys further to connect and after ca 25 seconds he sees that he cannot connect. At this point he stops the process cause the timeout already occured.

What i wanna say with this is, there is no difference with the command in PAExec between "-n 1", "-n 5", "-n 15", "-n 22" and all the others from 1 to 24. In every case he stops as soon as he realizes that he cannot connect.

-i: Do you mean when i set something as a session it should work ? ... When i do so, he connects, but my app, which i wanna start, returns only this exit code -1073741502 (0xC0000142)

-s and -cnodel are working fine now =D

-clist: Ok i didnt know that i have to write the executable file again after. I thought it would be enough if it stands in the txt-file. But no matter where i write the executable-file in the txt (beginning, somewhere in the middle or at the end) it works.

-csrc: So this is like "-c" but i can choose another destination, sounds good.

link

answered 31 Oct '12, 08:58

B%C3%B6rnib%C3%A4r's gravatar image

Börnibär
160114
accept rate: 0%

edited 31 Oct '12, 09:43

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×52
×17
×10

Asked: 30 Oct '12, 09:34

Seen: 20,247 times

Last updated: 17 Nov '12, 14:36