Hi! I'm currently testing PA Storage Monitor for my Company to shedule daily/weekly Directory growth Reports (including subdirs) worded fine for tweo weeks now. yesterday i have addes a satellite Service on another Location, configured the satellite Service to use the same database and configured a Monitor to scan fileserver on ethe othe rlocation threw the satellite Service Computer. during night sheduled Reports for central Monitoring Location worked, but satellite Service Monitor didn't start (even didn't appear unde rview System activity) today i deleted the Monitor from the remote sitze and recreated it, and now i get database error at remote satellite ... when ic chek database Connection directly on Satellit, it says ok. What am I doing wrong here?

asked 15 Dec '16, 05:36

G_PD's gravatar image

G_PD
152
accept rate: 0%


this is part of the PA Storage Monitor_Satellite_Log:

COMMIT TRAN; 12-15-2016, 11:38:13.862, TID:04308, PID:04028, SetCoreStatus: 3, id=8ea7072c-c21c-4f4b-92ca-3f2d276c0f47, #### SQLNumResultCols failed with [[ODBC Error: state=HY007, nativeErr=0, err=[Microsoft][ODBC SQL Server Driver]Die verbundene Anweisung ist nicht vorbereitet] ] for SQL=[SET NOCOUNT ON; BEGIN TRAN; INSERT INTO DIRECTORY (Path, ParentDirID) VALUES (N'\DIRECTORYPATH05_FUNDAMENTIERUNGÜBERHOLT', 1326452);

COMMIT TRAN;] 12-15-2016, 11:38:13.862, TID:04308, PID:04028, ERROR: #### SQLNumResultCols failed with [[ODBC Error: state=HY007, nativeErr=0, err=[Microsoft][ODBC SQL Server Driver]Die verbundene Anweisung ist nicht vorbereitet] ] for SQL=[SET NOCOUNT ON; BEGIN TRAN; INSERT INTO DIRECTORY (Path, ParentDirID) VALUES (N'\DIRECTORYPATH05_FUNDAMENTIERUNGÜBERHOLT', 1326452);

COMMIT TRAN;] 12-15-2016, 11:38:13.862, TID:04308, PID:04028, ERROR: SET NOCOUNT ON; BEGIN TRAN; INSERT INTO DIRECTORY (Path, ParentDirID) VALUES (N'\DIRECTORYPATH05_FUNDAMENTIERUNGÜBERHOLT', 1326452);

COMMIT TRAN; 12-15-2016, 11:38:13.893, TID:04484, PID:04028, SetCoreStatus: 3, id=8ea7072c-c21c-4f4b-92ca-3f2d276c0f47, #### SQLNumResultCols failed with [[ODBC Error: state=HY007, nativeErr=0, err=[Microsoft][ODBC SQL Server Driver]Die verbundene Anweisung ist nicht vorbereitet] ] for SQL=[SET NOCOUNT ON; BEGIN TRAN; INSERT INTO DIRECTORY (Path, ParentDirID) VALUES (N'\DIRECTORYPATH04_STATISCHE_BERECHNUNG_GEBAEUDEABLASTUNG', 0);

link

answered 15 Dec '16, 05:41

G_PD's gravatar image

G_PD
152
accept rate: 0%

Hi G_PD,

Restarting the Central Monitoring Service (ie the PA Storage Monitor service), and the Satellite service will force those processes to get new statID values from the database, which should fix this problem.

Thanks
Quinn

Please make sure to mark your questions accepted when you have your answer by clicking the gray check mark to the left of the answer.

link

answered 15 Dec '16, 11:36

Quinn's gravatar image

Quinn ♦♦
13.7k3925
accept rate: 39%

Hi!

After restarting error disappeared, but i noticed two things:

  • SQL Server CPU went up to about 40-50% cpu (now for days), when stopping stallite Service cpu goes down. Have never seen this with the central Monitoring.

  • Could ypu please clarify how datatransfer between satellite Service and central Monitoring runs? Maybe my error occur because i have set same database for central Monitorings ervice as in satellite Service........!?!?

  • When looking at the System logs, configured Monitor "Monitor storage" for satellite Service never starts. Daily shedule is set, but Reports still not possible. also worked without Problems as Long as only the cnetral Monitoring was running.

  • Now i have rached end of Trial licence. Is it possible to extend the Trial period? We will only buy PA storage Monitor when satellite Service runs without Problems...

Yours Gernot

link

answered 21 Dec '16, 10:52

G_PD's gravatar image

G_PD
152
accept rate: 0%

Hi Gernot,

Thank you for the questions.

Would you please zip up and send us the log files for the Central Service and the Satellite Service? We'll also need to know the name of the server and satellite, and the name of the monitor that you are not seeing start up. Also, Please right click on the monitor and report the status of that monitor and the last run date time.

We can also send you a new trial license so that you can keep testing. Please forward all of the above items to support@poweradmin.com

Thanks
Quinn

Please make sure to mark your questions accepted when you have your answer by clicking the gray check mark to the left of the answer.

link

answered 21 Dec '16, 14:26

Quinn's gravatar image

Quinn ♦♦
13.7k3925
accept rate: 39%

Sorry for my late answer, I reinstalled satellite Monitoring Service and used local database instead of SQL db, now everything works fine. I think my fault was that i have used the same SQL DB for the satellite and and centrals ervice....

link

answered 24 Jan, 03:21

G_PD's gravatar image

G_PD
152
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×13
×8

Asked: 15 Dec '16, 05:36

Seen: 781 times

Last updated: 24 Jan, 03:21